Information Disclosure Affecting github.com/hashicorp/vault/command Open this link in a new tab package, versions >=1.3.0 <1.3.6 >=1.4.0 <1.4.2


0.0
medium
  • Attack Complexity

    Low

  • Privileges Required

    High

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMHASHICORPVAULTCOMMAND-570191

  • published

    22 May 2020

  • disclosed

    22 May 2020

  • credit

    Unknown

How to fix?

Upgrade github.com/hashicorp/vault/command to version 1.3.6, 1.4.2 or higher.

Overview

github.com/hashicorp/vault/command is a tool for secrets management, encryption as a service, and privileged access management.

Affected versions of this package are vulnerable to Information Disclosure. Proxy environment variables such as URLs are logged by default. These would often include include usernames and passwords,