Improper Certificate Validation Affecting package, versions >=1.7.0 <1.7.1 <1.6.4

  • Attack Complexity


Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id


  • published

    26 Apr 2021

  • disclosed

    26 Apr 2021

  • credit

    Martin Sucha

How to fix?

Upgrade to version 1.7.1, 1.6.4 or higher.


Affected versions of this package are vulnerable to Improper Certificate Validation. Vault’s Cassandra integrations did not have TLS certificate validation enabled for connections to Cassandra clusters. As a result, Vault may have connected to Cassandra clusters without adequately verifying the trustworthiness of the remote service and connection.