Improper Input Validation Affecting github.com/hashicorp/vault-plugin-secrets-gcp/plugin Open this link in a new tab package, versions <0.6.2


0.0
medium
  • Attack Complexity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMHASHICORPVAULTPLUGINSECRETSGCPPLUGIN-570192

  • published

    22 May 2020

  • disclosed

    22 May 2020

  • credit

    Unknown

How to fix?

Upgrade github.com/hashicorp/vault-plugin-secrets-gcp/plugin to version 0.6.2 or higher.

Overview

github.com/hashicorp/vault-plugin-secrets-gcp/plugin is a backend plugin to be used with Hashicorp Vault.

Affected versions of this package are vulnerable to Improper Input Validation. System TTLs were being used instead of the configured backend TTLs for dynamic service accounts. This could potentially lead to dangerous behaviour and deviates from best practices.