Improper Validation Affecting github.com/hashicorp/vault-ssh-helper/helper package, versions <0.2.0


0.0
low
  • Attack Complexity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMHASHICORPVAULTSSHHELPERHELPER-608078

  • published

    21 Aug 2020

  • disclosed

    21 Aug 2020

  • credit

    Unknown

How to fix?

Upgrade github.com/hashicorp/vault-ssh-helper/helper to version 0.2.0 or higher.

Overview

github.com/hashicorp/vault-ssh-helper/helper is a counterpart to HashiCorp Vault's SSH backend. It allows a machine to consume One-Time-Passwords (OTP) created by Vault servers by allowing them to be used as client authentication credentials at SSH connection time.

Affected versions of this package are vulnerable to Improper Validation. It incorrectly accepts Vault-issued SSH OTPs for the subnet in which a host's network interface was located, rather than the specific IP address assigned to that interface.