Improper Authentication Affecting github.com/hashicorp/vault/vault package, versions <1.6.2


0.0
medium

Snyk CVSS

    Attack Complexity Low
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMHASHICORPVAULTVAULT-1066569
  • published 2 Feb 2021
  • disclosed 2 Feb 2021
  • credit Unknown

How to fix?

Upgrade github.com/hashicorp/vault/vault to version 1.6.2 or higher.

Overview

github.com/hashicorp/vault/vault is a tool for securely accessing secrets.

Affected versions of this package are vulnerable to Improper Authentication. It allowed the remove-peer raft operator command to be executed against DR secondaries without authentication.

References