Insecure Permissions Affecting github.com/hashicorp/vault/vault package, versions >=v1.8.0


0.0
medium

Snyk CVSS

    Attack Complexity High
    User Interaction Required
    Confidentiality High
    Integrity High
Expand this section
NVD
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMHASHICORPVAULTVAULT-1730066
  • published 11 Oct 2021
  • disclosed 11 Oct 2021
  • credit mdgreenfield

How to fix?

Upgrade github.com/hashicorp/vault/vault to version or higher.

Overview

github.com/hashicorp/vault/vault is a tool for securely accessing secrets.

Affected versions of this package are vulnerable to Insecure Permissions due to an unexpected interaction between glob-related policies and the Google Cloud secrets engine. Users may, in some situations, have more privileges than intended, e.g., a user with read permission for the /gcp/roleset/* path may be able to issue Google Cloud service account credentials.

References