Insecure Defaults Affecting package, versions >=1.8.0 <1.8.5 <1.7.6

  • Attack Complexity


Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id


  • published

    1 Dec 2021

  • disclosed

    1 Dec 2021

  • credit


How to fix?

Upgrade to version 1.8.5, 1.7.6 or higher.

Overview is a tool for securely accessing secrets.

Affected versions of this package are vulnerable to Insecure Defaults. Templated ACL policies would always match the first-created entity alias if multiple entity aliases existed for a specified entity and mount combination, potentially resulting in incorrect policy enforcement.