Improper Authentication Affecting github.com/hashicorp/vault/vault Open this link in a new tab package, versions >=1.10.0 <1.10.3


0.0
medium
  • Attack Complexity

    High

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMHASHICORPVAULTVAULT-2833363

  • published

    18 May 2022

  • disclosed

    18 May 2022

  • credit

    Unknown

How to fix?

Upgrade github.com/hashicorp/vault/vault to version 1.10.3 or higher.

Overview

github.com/hashicorp/vault/vault is a tool for securely accessing secrets.

Affected versions of this package are vulnerable to Improper Authentication by not correctly configuring and enforcing MFA on login after server restarts.