Authentication Bypass Affecting github.com/hashicorp/vault/vault Open this link in a new tab package, versions >=0.8.3 <1.2.5 >=1.3.0 <1.3.8 >=1.4.0 <1.4.4 >=1.5.0 <1.5.1


0.0
medium
  • Attack Complexity

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMHASHICORPVAULTVAULT-608842

  • published

    27 Aug 2020

  • disclosed

    27 Aug 2020

  • credit

    Felix Wilhelm

How to fix?

Upgrade github.com/hashicorp/vault/vault to version 1.2.5, 1.3.8, 1.4.4, 1.5.1 or higher.

Overview

github.com/hashicorp/vault/vault is a tool for securely accessing secrets.

Affected versions of this package are vulnerable to Authentication Bypass. When using the GCP GCE Auth Method, under certain circumstances, values Vault uses to validate GCE VMs can be manipulated and bypassed.