Improper Input Validation Affecting github.com/helm/helm/pkg/repo Open this link in a new tab package, versions >=2.0.0 <2.16.11 >=3.0.0 <3.3.2


0.0
low
  • Attack Complexity

    High

  • Privileges Required

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMHELMHELMPKGREPO-1009822

  • published

    18 Sep 2020

  • disclosed

    18 Sep 2020

  • credit

    Unknown

How to fix?

Upgrade github.com/helm/helm/pkg/repo to version 2.16.11, 3.3.2 or higher.

Overview

github.com/helm/helm/pkg/repo is a package manager for kubernetes.

Affected versions of this package are vulnerable to Improper Input Validation. A Helm repository can contain duplicates of the same chart, with the last one always used. If a repository is compromised, this lowers the level of access that an attacker needs to inject a bad chart into a repository. To perform this attack, an attacker must have write access to the index file (which can occur during a MITM attack on a non-SSL connection).