Improper Restriction of Communication Channel to Intended Endpoints Affecting github.com/hpcng/singularity/e2e/actions package, versions >=3.7.2 <3.7.4


0.0
high
  • Attack Complexity

    High

  • User Interaction

    Required

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMHPCNGSINGULARITYE2EACTIONS-1298033

  • published

    30 May 2021

  • disclosed

    30 May 2021

  • credit

    Mike Frisch

How to fix?

Upgrade github.com/hpcng/singularity/e2e/actions to version 3.7.4 or higher.

Overview

Affected versions of this package are vulnerable to Improper Restriction of Communication Channel to Intended Endpoints. Singularity commands specifying a container using a library:// URI will ignore the configured remote endpoint, and attempt to retrieve the container from the default endpoint (cloud.sylabs.io). This may allow an attacker to push and execute a malicious container to a victim with a non-default remote endpoint.