Improper Validation of an Integrity Check Value Affecting github.com/hpcng/singularity/internal/pkg Open this link in a new tab package, versions <3.6.0


0.0
high
  • Attack Complexity

    Low

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMHPCNGSINGULARITYINTERNALPKG-2322171

  • published

    21 Dec 2021

  • disclosed

    20 Dec 2021

  • credit

    Adam Hughes

How to fix?

Upgrade github.com/hpcng/singularity/internal/pkg to version 3.6.0 or higher.

Overview

Affected versions of this package are vulnerable to Improper Validation of an Integrity Check Value. Image integrity is not validated when an ECL policy is enforced. The fingerprint required by the ECL is compared against the signature object descriptor(s) in the SIF file, rather than to a cryptographically validated signature.