Insecure Permissions Affecting github.com/hpcng/singularity/pkg/build/types Open this link in a new tab package, versions <3.6.3


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMHPCNGSINGULARITYPKGBUILDTYPES-1296548

  • published

    25 May 2021

  • disclosed

    24 May 2021

  • credit

    David Trudgian, Adam Hughes

How to fix?

Upgrade github.com/hpcng/singularity/pkg/build/types to version 3.6.3 or higher.

Overview

github.com/hpcng/singularity/pkg/build/types is an application containers for Linux.

Affected versions of this package are vulnerable to Insecure Permissions. When a command that results in a container build operation is executed, it is possible for a user with access to the system to read the contents of the image during the build. Additionally, if the image contains a world-writable file or directory, it is possible for a user to inject arbitrary content into the running build, which in certain circumstances may enable arbitrary code execution during the build and/or when the built container is run.

References