Insecure Defaults Affecting github.com/hybridgroup/gobot/platforms/mqtt package, versions <1.13.0


0.0
medium

Snyk CVSS

    Attack Complexity High
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMHYBRIDGROUPGOBOTPLATFORMSMQTT-174852
  • published 2 Jun 2019
  • disclosed 21 May 2019
  • credit Unknown

How to fix?

Upgrade github.com/hybridgroup/gobot/platforms/mqtt to version 1.13.0 or higher.

Overview

github.com/hybridgroup/gobot/platforms/mqtt is a Golang framework for robotics, drones, and the Internet of Things (IoT).

Affected versions of this package are vulnerable to Insecure Defaults. It skipped verification of root CA certificates by using default InsecureSkipVerify.