Improper Input Validation Affecting github.com/ipfs/go-ipfs package, versions <0.8.0


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Scope

    Changed

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMIPFSGOIPFS-1088989

  • published

    26 Mar 2021

  • disclosed

    25 Mar 2021

  • credit

    @tintinweb

How to fix?

Upgrade github.com/ipfs/go-ipfs to version 0.8.0 or higher.

Overview

github.com/ipfs/go-ipfs is a go-ipfs is an open-source golang implementation of IPFS which is a global, versioned, peer-to-peer filesystem.

Affected versions of this package are vulnerable to Improper Input Validation. Control characters are not escaped from console output, which can lead to hidden user input that may contain malicious actions.