Authorization Bypass Affecting github.com/istio/istio/pilot/pkg/networking/core/v1alpha3 package, versions >=1.9.0 <1.9.5 <1.8.6


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMISTIOISTIOPILOTPKGNETWORKINGCOREV1ALPHA3-1299108

  • published

    3 Jun 2021

  • disclosed

    3 Jun 2021

  • credit

    @Ruilin,@Test123

How to fix?

Upgrade github.com/istio/istio/pilot/pkg/networking/core/v1alpha3 to version 1.9.5, 1.8.6 or higher.

Overview

Affected versions of this package are vulnerable to Authorization Bypass. An HTTP request path with multiple slashes or escaped slash characters (e.g. %2F or %5C) could potentially bypass an Istio authorization policy when path-based authorization rules are used.