Information Exposure Affecting github.com/jaegertracing/jaeger/pkg/kafka/auth Open this link in a new tab package, versions <1.18.1


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMJAEGERTRACINGJAEGERPKGKAFKAAUTH-674508

  • published

    19 Jun 2020

  • disclosed

    17 Jun 2020

  • credit

    Carl Henrik Lunde

How to fix?

Upgrade github.com/jaegertracing/jaeger/pkg/kafka/auth to version 1.18.1 or higher.

Overview

github.com/jaegertracing/jaeger/pkg/kafka/auth is a distributed tracing platform.

Affected versions of this package are vulnerable to Information Exposure. Sensitive information is written to a log file when the Kafka data store is used. This flaw allows an attacker with access to the container's log file to discover the Kafka credentials.