Arbitrary Command Execution Affecting github.com/keybase/client/go/client package, versions <5.6.0


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMKEYBASECLIENTGOCLIENT-2320185

  • published

    15 Dec 2021

  • disclosed

    15 Dec 2021

  • credit

    RyotaK

How to fix?

Upgrade github.com/keybase/client/go/client to version 5.6.0 or higher.

Overview

Affected versions of this package are vulnerable to Arbitrary Command Execution when a user executed the keybase git lfs-config command on the command-line.

References