Insufficient Validation Affecting github.com/kiali/kiali/handlers package, versions <1.16.0-snapshot.1


Severity

Recommended
0.0
medium
0
10

CVSS assessment made by Snyk's Security Team

    Threat Intelligence

    EPSS
    0.27% (68th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMKIALIKIALIHANDLERS-561359
  • published 26 Mar 2020
  • disclosed 26 Mar 2020
  • credit Dagan Henderson

How to fix?

Upgrade github.com/kiali/kiali/handlers to version 1.16.0-snapshot.1 or higher.

Overview

github.com/kiali/kiali/handlers is a handler package part of kiali.

Affected versions of this package are vulnerable to Insufficient Validation. A remote attacker could abuse this flaw by stealing a valid JWT cookie and using that to spoof a user session, possibly gaining privileges to view and alter the Istio configuration.

CVSS Scores

version 3.1
Expand this section

Snyk

5.9 medium
  • Attack Vector (AV)
    Network
  • Attack Complexity (AC)
    High
  • Privileges Required (PR)
    None
  • User Interaction (UI)
    None
  • Scope (S)
    Unchanged
  • Confidentiality (C)
    High
  • Integrity (I)
    None
  • Availability (A)
    None
Expand this section

NVD

8.6 high
Expand this section

Red Hat

7 high