Insecure Defaults Affecting github.com/kubernetes/kubernetes/pkg/features Open this link in a new tab package, versions >=1.10.0 <1.14.0-alpha.2


0.0
low
  • Attack Complexity

    High

  • Privileges Required

    High

  • User Interaction

    Required

  • Scope

    Changed

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMKUBERNETESKUBERNETESPKGFEATURES-536847

  • published

    5 Dec 2019

  • disclosed

    5 Dec 2019

  • credit

    Alban Crequy

How to fix?

Upgrade github.com/kubernetes/kubernetes/pkg/features to version 1.14.0-alpha.2 or higher.

Overview

github.com/kubernetes/kubernetes/pkg/features is a package that is part of Kubernetes.

Affected versions of this package are vulnerable to Insecure Defaults. The ValidateProxyRedirects feature can be manually enabled with the kube-apiserver flag --feature-gates=ValidateProxyRedirects=true but it's not enabled by default. The fix enables it by default.