Arbitrary Command Injection Affecting github.com/kubernetes/kubernetes/pkg/util/mount Open this link in a new tab package, versions >=1.9.0 <1.9.10 >=1.10.0 <1.10.6 >=1.11.0 <1.11.2


0.0
high
  • Attack Complexity

    High

  • User Interaction

    Required

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMKUBERNETESKUBERNETESPKGUTILMOUNT-72885

  • published

    3 Jan 2019

  • disclosed

    3 Jul 2018

  • credit

    andyzhangx

How to fix?

Upgrade github.com/kubernetes/kubernetes/pkg/util/mount to version 1.9.10, 1.10.6, 1.11.2 or higher.

Overview

github.com/kubernetes/kubernetes/pkg/util/mount is a Production-Grade Container Scheduling and Management.

Affected versions of this package are vulnerable to Arbitrary Command Injection. User input was handled insecurely while setting up volume mounts on Windows nodes, which could lead to command line argument injection.