Privilege Escalation Affecting github.com/kubernetes/kubernetes/staging/src/k8s.io/apimachinery/pkg/util/proxy Open this link in a new tab package, versions <1.10.11 >=1.11.0 <1.11.5 >=1.12.0 <1.12.3
Proof of concept
Do your applications use this vulnerable package?
In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.Test your applications
10 Dec 2018
5 Dec 2018
How to fix?
github.com/kubernetes/kubernetes/staging/src/k8s.io/apimachinery/pkg/util/proxy to version 1.10.11, 1.11.5, 1.12.3 or higher.
github.com/kubernetes/kubernetes/staging/src/k8s.io/apimachinery/pkg/util/proxy is a package that provides transport and upgrade support for proxies.
Affected versions of this package are vulnerable to Privilege Escalation. Incorrect handling of error responses to proxied upgrade requests in the
kube-apiserver allowed specially crafted requests to establish a connection through the Kubernetes API server to backend servers, then send arbitrary requests over the same connection directly to the backend, authenticated with the Kubernetes API server's TLS credentials used to establish the backend connection.