Credential Exposure Affecting github.com/kubernetes/kubernetes/staging/src/k8s.io/client-go/transport package, versions <1.16.0


0.0
medium
  • Attack Complexity

    Low

  • Privileges Required

    High

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMKUBERNETESKUBERNETESSTAGINGSRCK8SIOCLIENTGOTRANSPORT-1325546

  • published

    25 Jul 2021

  • disclosed

    14 Apr 2021

  • credit

    Unknown

How to fix?

Upgrade github.com/kubernetes/kubernetes/staging/src/k8s.io/client-go/transport to version 1.16.0 or higher.

Overview

Affected versions of this package are vulnerable to Credential Exposure. When the verbosity level is set to debug, authorization tokens are logged.