Privilege Escalation Affecting github.com/kubevirt/kubevirt/pkg/virt-api/webhooks/validating-webhook package, versions <0.30.0


0.0
medium

Snyk CVSS

    Attack Complexity High
    Privileges Required High
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.09% (36th percentile)
Expand this section
NVD
9.9 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMKUBEVIRTKUBEVIRTPKGVIRTAPIWEBHOOKSVALIDATINGWEBHOOK-596512
  • published 30 Jul 2020
  • disclosed 30 Jul 2020
  • credit Unknown

How to fix?

Upgrade github.com/kubevirt/kubevirt/pkg/virt-api/webhooks/validating-webhook to version 0.30.0 or higher.

Overview

Affected versions of this package are vulnerable to Privilege Escalation. Virtual Machine Instances (VMIs) can be used to gain access to the host's filesystem. Successful exploitation allows an attacker to assume the privileges of the VM process on the host system. In worst-case scenarios an attacker can read and modify any file on the system where the VMI is running.