Improper Validation Affecting github.com/lightningnetwork/lnd package, versions <0.10.0-beta


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMLIGHTNINGNETWORKLND-1047780

  • published

    2 Dec 2020

  • disclosed

    2 Dec 2020

  • credit

    Antoine Riard

How to fix?

Upgrade github.com/lightningnetwork/lnd to version 0.10.0-beta or higher.

Overview

github.com/lightningnetwork/lnd is a complete implementation of a Lightning Network node.

Affected versions of this package are vulnerable to Improper Validation. It accepts a counterparty high-S signature and broadcasts tx-relay invalid local commitment/HTLC transactions.

References