Improper Input Validation Affecting github.com/luraproject/lura/v2/router/gin package, versions <2.0.2


0.0
medium
  • Attack Complexity

    High

  • Scope

    Changed

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMLURAPROJECTLURAV2ROUTERGIN-2964944

  • published

    2 Aug 2022

  • disclosed

    2 Aug 2022

  • credit

    Fepame

How to fix?

Upgrade github.com/luraproject/lura/v2/router/gin to version 2.0.2 or higher.

Overview

github.com/luraproject/lura/v2/router/gin is a framework to assemble ultra performance API Gateways with middlewares; formerly known as KrakenD framework, and core service of the KrakenD API Gateway

Affected versions of this package are vulnerable to Improper Input Validation due to improper sanitization of URL parameters. A malicious user can alter the backend URL defined for a pipe when remote users send crafty URL requests.