Information Exposure Affecting github.com/lxc/lxd Open this link in a new tab package, versions <2.0.2


0.0
medium
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMLXCLXD-50039

  • published

    26 May 2016

  • disclosed

    26 May 2016

  • credit

    Unknown

Overview

Affected version of github.com/lxc/lxd are vulnerable to Information Exposure. LXD before 2.0.2 does not properly set permissions when switching an unprivileged container into privileged mode, which allows local users to access arbitrary world readable paths in the container directory via unspecified vectors.

References