Information Exposure Affecting github.com/mattermost/mattermost-server/v6 package, versions <6.3.9 >=6.4.0 <6.5.2 >=6.6.0 <6.6.2 >=6.7.0 <6.7.1


0.0
medium
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMMATTERMOSTMATTERMOSTSERVERV6-2950825

  • published

    15 Jul 2022

  • disclosed

    15 Jul 2022

  • credit

    Elias

How to fix?

Upgrade github.com/mattermost/mattermost-server/v6 to version 6.3.9, 6.5.2, 6.6.2, 6.7.1 or higher.

Overview

github.com/mattermost/mattermost-server/v6 is an open source, private cloud, Slack-alternative.

Affected versions of this package are vulnerable to Information Exposure which allows team members to access some sensitive information by directly accessing the APIs.