Access Control Bypass Affecting github.com/mattermost/mattermost-server/v6/api Open this link in a new tab package, versions <6.2.0


0.0
low
  • Attack Complexity

    High

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMMATTERMOSTMATTERMOSTSERVERV6API-2347627

  • published

    19 Jan 2022

  • disclosed

    19 Jan 2022

  • credit

    Unknown

How to fix?

Upgrade github.com/mattermost/mattermost-server/v6/api to version 6.2.0 or higher.

Overview

github.com/mattermost/mattermost-server/v6/api is an open source, private cloud, Slack-alternative from https://mattermost.com.

Affected versions of this package are vulnerable to Access Control Bypass which allows authenticated users to view contents of archived channels even when this is denied by system administrators by directly accessing the APIs.