Arbitrary Code Execution Affecting github.com/michaelmure/git-bug/repository package, versions <0.7.2


0.0
high
  • Attack Complexity

    Low

  • Privileges Required

    High

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMMICHAELMUREGITBUGREPOSITORY-1088077

  • published

    22 Mar 2021

  • disclosed

    22 Mar 2021

  • credit

    Unknown

How to fix?

Upgrade github.com/MichaelMure/git-bug/repository to version 0.7.2 or higher.

Overview

Affected versions of this package are vulnerable to Arbitrary Code Execution. It will execute git.bat from the current directory in certain PATH situations (most often seen on Windows).

References