Authentication Bypass Affecting github.com/moby/moby package, versions <17.3.2-ce


0.0
high
  • Attack Complexity

    Low

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMMOBYMOBY-72364

  • published

    13 Sep 2018

  • disclosed

    12 May 2017

  • credit

    MorphBonehunter

How to fix?

Upgrade moby to version 17.3.2-ce or higher.

Overview

github.com/moby/moby is a collaborative project for the container ecosystem to assemble container-based systems.

Affected versions of this package are vulnerable to Authentication Bypass. The Docker engine validated a client TLS certificate using both the configured client CA root certificate and all system roots on non-Windows systems. This allowed a client with any domain validated certificate signed by a system-trusted root CA to authenticate.