Improper Input Validation Affecting github.com/mongodb/mongo-go-driver/bson/bsonrw Open this link in a new tab package, versions <1.5.1


0.0
medium
  • Attack Complexity

    High

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMMONGODBMONGOGODRIVERBSONBSONRW-1303392

  • published

    11 Jun 2021

  • disclosed

    11 Jun 2021

  • credit

    Divjot Arora

How to fix?

Upgrade github.com/mongodb/mongo-go-driver/bson/bsonrw to version 1.5.1 or higher.

Overview

github.com/mongodb/mongo-go-driver/bson/bsonrw is a The MongoDB supported driver for Go.

Affected versions of this package are vulnerable to Improper Input Validation. Specific cstrings input may not be properly validated in the MongoDB Go Driver when marshalling Go objects into BSON. A malicious user could use a Go object with specific string to potentially inject additional fields into marshalled documents.