Information Exposure Affecting github.com/netlify/gotrue/api package, versions <1.0.0


0.0
low

Snyk CVSS

    Attack Complexity Low
    Privileges Required High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMNETLIFYGOTRUEAPI-1019459
  • published 22 Nov 2020
  • disclosed 2 Oct 2020
  • credit frontcraft

How to fix?

Upgrade github.com/netlify/gotrue/api to version 1.0.0 or higher.

Overview

github.com/netlify/gotrue/api is a SWT based API for managing users and issuing SWT tokens

Affected versions of this package are vulnerable to Information Exposure. User enumeration is possible via the "Log in" widget. An authentication request with wrong credentials at the login panel returns the message “No user found with this email”.