Buffer Overflow Affecting github.com/opencontainers/runc/libcontainer package, versions <1.0.3


0.0
high

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    EPSS 0.82% (82nd percentile)
Expand this section
NVD
5 medium
Expand this section
SUSE
5 medium
Expand this section
Red Hat
5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMOPENCONTAINERSRUNCLIBCONTAINER-2309909
  • published 6 Dec 2021
  • disclosed 6 Dec 2021
  • credit Felix Wilhelm

How to fix?

Upgrade github.com/opencontainers/runc/libcontainer to version 1.0.3 or higher.

Overview

github.com/opencontainers/runc/libcontainer is a package for a modern container runtime.

Affected versions of this package are vulnerable to Buffer Overflow when writing netlink messages. It is possible to have a byte array larger than UINT16_MAX which would result in the length field overflowing and allowing user-controlled data to be parsed as control characters.