Sensitive Data Exposure Affecting github.com/openshift/library-go/pkg/operator/resource/resourceapply Open this link in a new tab package, versions >=4.0 <4.1


0.0
low
  • Attack Complexity

    Low

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMOPENSHIFTLIBRARYGOPKGOPERATORRESOURCERESOURCEAPPLY-472066

  • published

    8 Oct 2019

  • disclosed

    29 Sep 2019

  • credit

    Unknown

How to fix?

Upgrade github.com/openshift/library-go/pkg/operator/resource/resourceapply to version 4.1 or higher.

Overview

github.com/openshift/library-go/pkg/operator/resource/resourceapply is a package for creating helpers for going from apis and clients to useful runtime constructs.

Affected versions of this package are vulnerable to Sensitive Data Exposure. None