Privilege Escalation Affecting github.com/openshift/origin package, versions <1.1.1


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMOPENSHIFTORIGIN-50000
  • published 3 Feb 2016
  • disclosed 3 Feb 2016
  • credit Unknown

How to fix?

Upgrade github.com/openshift/origin to version 1.1.1 or higher.

Overview

github.com/openshift/origin is a core Kubernetes tracking package.

Affected versions of this package are vulnerable to Privilege Escalation. The API server in Kubernetes might allow remote attackers to gain privileges by editing a build configuration to use a restricted strategy.