Improper Authentication Affecting github.com/openshift/router/pkg/router/template/util Open this link in a new tab package, versions *


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMOPENSHIFTROUTERPKGROUTERTEMPLATEUTIL-2824153

  • published

    13 May 2022

  • disclosed

    13 May 2022

  • credit

    Unknown

How to fix?

A fix was pushed into the master branch but not yet published.

Overview

Affected versions of this package are vulnerable to Improper Authentication. A user can craft a route that injects a bogus entry into one of the HAProxy configuration files. This bogus entry can match any arbitrary hostname, or all hostnames in the cluster, and direct traffic to an arbitrary application, including one belonging to the user who is performing the attack.