Improper Handling of Exceptional Conditions Affecting github.com/ory/fosite/handler/oauth2 package, versions <0.34.0


0.0
high
  • Attack Complexity

    High

  • User Interaction

    Required

  • Scope

    Changed

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMORYFOSITEHANDLEROAUTH2-1012739

  • published

    25 Sep 2020

  • disclosed

    25 Sep 2020

  • credit

    Unknown

How to fix?

Upgrade github.com/ory/fosite/handler/oauth2 to version 0.34.0 or higher.

Overview

github.com/ory/fosite/handler/oauth2 is an OAuth2 & OpenID Connect framework for Go.

Affected versions of this package are vulnerable to Improper Handling of Exceptional Conditions. The TokenRevocationHandler ignores errors coming from the storage. This can lead to unexpected 200 status codes indicating successful revocation while the token is still valid. Whether an attacker can use this for her advantage depends on the ability to trigger errors in the store.