Information Exposure Affecting github.com/pingcap/tidb/session package, versions <4.0.6


0.0
medium

Snyk CVSS

    Attack Complexity Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMPINGCAPTIDBSESSION-608945
  • published 30 Aug 2020
  • disclosed 30 Aug 2020
  • credit wwar

How to fix?

Upgrade github.com/pingcap/tidb/session to version 4.0.6 or higher.

Overview

github.com/pingcap/tidb/session is a NewSQL database that supports Hybrid Transactional and Analytical Processing (HTAP) workloads.

Affected versions of this package are vulnerable to Information Exposure. mysql_list_fields leaks table info due to the binary protocol not being checked correctly.

References