Buffer Overflow Affecting github.com/pion/dtls/v2 Open this link in a new tab package, versions <2.1.4


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMPIONDTLSV2-2841485

  • published

    22 May 2022

  • disclosed

    22 May 2022

  • credit

    Juho Nurminen and the Mattermost team

How to fix?

Upgrade github.com/pion/dtls/v2 to version 2.1.4 or higher.

Overview

github.com/pion/dtls/v2 is a DTLS 1.2 Server/Client implementation for Go.

Affected versions of this package are vulnerable to Buffer Overflow because an attacker can exploit the network traffic that doesn't have an upper limit bound. It can cause excessive memory usage.