Access Restriction Bypass Affecting github.com/pomerium/pomerium Open this link in a new tab package, versions >=0.15.0 <0.15.1 <0.14.8


0.0
high
  • Attack Complexity

    Low

  • Scope

    Changed

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMPOMERIUMPOMERIUM-1584107

  • published

    11 Sep 2021

  • disclosed

    10 Sep 2021

  • credit

    Unknown

How to fix?

Upgrade github.com/pomerium/pomerium to version 0.15.1, 0.14.8 or higher.

Overview

github.com/pomerium/pomerium is an identity-aware proxy that enables secure access to internal applications.

Affected versions of this package are vulnerable to Access Restriction Bypass. Envoy, which Pomerium is based on, contains two authorization-related vulnerabilities CVE-2021-32777 and CVE-2021-32779. This may lead to incorrect routing or authorization policy decisions. With specially crafted requests, incorrect authorization or routing decisions may be made by Pomerium.

This issue can only be triggered when using path prefix based policy. Removing any such policies should provide mitigation.