Improper Authorization Affecting github.com/pomerium/pomerium Open this link in a new tab package, versions >=0.14.0 <0.15.6


0.0
medium
  • Attack Complexity

    High

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMPOMERIUMPOMERIUM-1912614

  • published

    7 Nov 2021

  • disclosed

    7 Nov 2021

  • credit

    Unknown

How to fix?

Upgrade github.com/pomerium/pomerium to version 0.15.6 or higher.

Overview

github.com/pomerium/pomerium is an identity-aware proxy that enables secure access to internal applications.

Affected versions of this package are vulnerable to Improper Authorization when using allowed_idp_claims, changes to the OIDC claims of a user after initial login are not reflected in policy evaluation. If so, Pomerium can make incorrect authorization decisions.