Information Exposure Affecting github.com/projectatomic/oci-register-machine package, versions <0.0.3


0.0
low

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    EPSS 0.04% (6th percentile)
Expand this section
NVD
3.3 low
Expand this section
Red Hat
4 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMPROJECTATOMICOCIREGISTERMACHINE-50040
  • published 26 Jul 2016
  • disclosed 26 Jul 2016
  • credit Unknown

How to fix?

Upgrade github.com/projectatomic/oci-register-machine to version 0.0.3 or higher.

Overview

Affected versions of this package are vulnerable to Information Exposure. The machinectl command in oci-register-machine allows local users to list running containers and possibly obtain sensitive information by running that command.