Information Exposure Affecting github.com/projectcalico/calico/api/pkg/apis/projectcalico/v3 Open this link in a new tab package, versions <3.21.5 >=3.22.0 <3.22.2


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMPROJECTCALICOCALICOAPIPKGAPISPROJECTCALICOV3-2859811

  • published

    7 Jun 2022

  • disclosed

    7 Jun 2022

  • credit

    Aloys Augustin

How to fix?

Upgrade github.com/projectcalico/calico/api/pkg/apis/projectcalico/v3 to version 3.21.5, 3.22.2 or higher.

Overview

Affected versions of this package are vulnerable to Information Exposure via the floating IP feature, due to insufficient validation. A privileged attacker may be able to set a floating IP annotation to a pod even if the feature is not enabled. Exploiting this vulnerability may allow the attacker to intercept and reroute traffic to their compromised pod.