Subdomain Takeover Affecting github.com/projectdiscovery/interactsh/pkg/server Open this link in a new tab package, versions <1.0.0


0.0
high
  • Attack Complexity

    Low

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMPROJECTDISCOVERYINTERACTSHPKGSERVER-2386860

  • published

    28 Jan 2022

  • disclosed

    27 Jan 2022

  • credit

    Unknown

Introduced: 27 Jan 2022

CWE-79 Open this link in a new tab

How to fix?

Upgrade github.com/projectdiscovery/interactsh/pkg/server to version 1.0.0 or higher.

Overview

github.com/projectdiscovery/interactsh/pkg/server is an an open-source tool for detecting out-of-band interactions.

Affected versions of this package are vulnerable to Subdomain Takeover of the app subdomain via the default config of the interactsh server. The interactsh server creates cname entries for app pointing to projectdiscovery.github.io by default, which was supposed to be used to host a web-client using GitHub Pages, however, when the web-client wasn't configured, cname entries were still being created. A victim browsing to that subdomain may be a victim of XSS.