Cross-site Request Forgery (CSRF) Affecting github.com/rancher/rancher/pkg/clusterrouter package, versions >=2.0.0 <2.0.16 >=2.1.0 <2.1.11 >=2.2.0 <2.2.5


0.0
high

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Scope Changed
    Confidentiality High
    Availability High
Expand this section
NVD
6.1 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMRANCHERRANCHERPKGCLUSTERROUTER-460823
  • published 4 Sep 2019
  • disclosed 4 Sep 2019
  • credit Matt Belisle, Alex Stevenson

How to fix?

Upgrade github.com/rancher/rancher/pkg/clusterrouter to version 2.0.16, 2.1.11, 2.2.5 or higher.

Overview

github.com/rancher/rancher/pkg/clusterrouter is a project that provides a container management platform built for organizations that deploy containers in production

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). It allows an exploiter to gain access to clusters managed by Rancher. The attack requires a victim to be logged into a Rancher server, and then to access a third-party site hosted by the exploiter. The exploiter is then able to execute commands against the victims' cluster's Kubernetes API with the permissions and identity of the victim.