Insecure Randomness Affecting package, versions >=1.49.0 <1.53.3



    Attack Complexity Low

    Threat Intelligence

    EPSS 0.14% (49th percentile)
Expand this section
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • published 11 Jun 2021
  • disclosed 10 Jun 2021
  • credit Unknown

How to fix?

Upgrade to version 1.53.3 or higher.


Affected versions of this package are vulnerable to Insecure Randomness. Due to the use of a weak random number generator, the password generator has been producing weak passwords with much less entropy than advertised. The suggested passwords depend deterministically on the time the second rclone was started. This limits the entropy of the passwords enormously. These passwords are often used in the crypt backend for encryption of data. It would be possible to make a dictionary of all possible passwords with about 38 million entries per password length. This would make decryption of secret material possible with a plausible amount of effort.

NOTE: all passwords generated by affected versions should be changed.