Improper Certificate Validation Affecting github.com/sigstore/cosign/cmd/cosign/cli/verify package, versions <1.5.2


0.0
low

Snyk CVSS

    Attack Complexity Low
Expand this section
NVD
3.3 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMSIGSTORECOSIGNCMDCOSIGNCLIVERIFY-2407587
  • published 20 Feb 2022
  • disclosed 20 Feb 2022
  • credit Zack Newman, dlorenc, Matt Moore, priyawadhwa, Nathan Smith

How to fix?

Upgrade github.com/sigstore/cosign/cmd/cosign/cli/verify to version 1.5.2 or higher.

Overview

github.com/sigstore/cosign/cmd/cosign/cli/verify is a package that aims to make signatures invisible infrastructure.

Affected versions of this package are vulnerable to Improper Certificate Validation by making it claim that an entry for a signature exists in the Rekor transparency log even if it doesn't. This requires the attacker to have pull and push permissions for the signature in OCI. This can happen with both standard signing with a keypair and "keyless signing" with Fulcio.