Cryptographic Issues Affecting github.com/sigstore/cosign/cmd/cosign/cli/verify package, versions <1.10.1


0.0
medium

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity High
    User Interaction Required
    Confidentiality High
    Integrity High
Expand this section
NVD
9.8 critical
Expand this section
SUSE
6.2 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-GOLANG-GITHUBCOMSIGSTORECOSIGNCMDCOSIGNCLIVERIFY-2975404
  • published 5 Aug 2022
  • disclosed 5 Aug 2022
  • credit mattmoor

How to fix?

Upgrade github.com/sigstore/cosign/cmd/cosign/cli/verify to version 1.10.1 or higher.

Overview

github.com/sigstore/cosign/cmd/cosign/cli/verify is a package that aims to make signatures invisible infrastructure.

Affected versions of this package are vulnerable to Cryptographic Issues when signing with a standard keypair and with "keyless" signing with Fulcio.

References