Authentication Bypass Affecting github.com/snapcore/snapd/daemon Open this link in a new tab package, versions >=2.27 <2.29.3


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMSNAPCORESNAPDDAEMON-50060

  • published

    14 Feb 2018

  • disclosed

    2 Aug 2017

  • credit

    John Lenton

Overview

Affected versions of github.com/snapcore/snapd/daemon are vulnerable to Authentication Bypass. The snap logs command could be made to call journalctl without match arguments and therefore allow unprivileged, unauthenticated users to bypass systemd-journald's access restrictions.

Remediation

Upgrade github.com/snapcore/snapd/daemon to version 2.9.3 or higher.